XHTML et W3C

Tous les benchmarks, vos résultats, vos tests.
Vos programmes, vos conseils logiciel
Votre matos, vos problèmes
Répondre
Avatar du membre
Davidazerty
l'élu
Messages : 2369
Enregistré le : octobre 12th, 2002, 3:30 pm

XHTML et W3C

#1

Message par Davidazerty » mai 16th, 2005, 2:28 pm

Pour résumer j'ai un probleme de validation de page web en XHTML.

En XHTML les mono-balises nécessitent de mettre /> à fin au lieu de > (ex: <img />, <br />). Donc je mets /> là où faut, et il me sort ca :

Code : Tout sélectionner

Line 8, column 88: end tag for "link" omitted, but OMITTAG NO was specified

<link rel="stylesheet" media="all" href="index.php_fichiers/custo.css" type="text/css">

You may have neglected to close a tag, or perhaps you meant to "self-close" a tag; that is, ending it with "/>" instead of ">"
Source:

Code : Tout sélectionner

<LINK rel="stylesheet" media="all" href="../include/custo.css" type="text/css" />
Là, je comprend pas :confused:

NB: je check en upload file.

nightblade
Bernard pivot
Messages : 837
Enregistré le : janvier 15th, 2003, 5:47 pm

#2

Message par nightblade » mai 16th, 2005, 2:51 pm

bin t'a un probléme d'upload car ton erreur et le code ne sont pas les même!!

Code : Tout sélectionner

<link rel="stylesheet" media="all" href="index.php_fichiers/custo.css" type="text/css"> 
est différent de :

Code : Tout sélectionner

<link rel="stylesheet" media="all" href="index.php_fichiers/custo.css" type="text/css" /> 

Avatar du membre
Davidazerty
l'élu
Messages : 2369
Enregistré le : octobre 12th, 2002, 3:30 pm

#3

Message par Davidazerty » mai 16th, 2005, 3:11 pm

J'ai l'impression que c'est un probleme d'enregistrement de la page html. Quand je regarde la source de la page les /> y sont bien, mais si j'enregistre la page pour upload, les /> sont remplacé par des >.
Si vous avez une solution :mlc:

Avatar du membre
Davidazerty
l'élu
Messages : 2369
Enregistré le : octobre 12th, 2002, 3:30 pm

#4

Message par Davidazerty » mai 16th, 2005, 3:34 pm

C'est bon j'ai trouvé, il suffit de faire enregistrer l'HTML uniquement, sinon il reformate pour mettre les images. :wink:

PS: en XHTML évitez de mettre vos balises en MAJ, sinon il risque de les prendres pour des balises XML et de vous dire qu'elles ne sont pas définit !

Répondre