Utilisez un navigateur moderne qui respecte votre vie privée : Téléchargez Firefox

Créer un Site

Tous les benchmarks, vos résultats, vos tests.
Vos programmes, vos conseils logiciel
Votre matos, vos problèmes
Avatar du membre
Christophe
L’humanité parlementaire
Réactions :
Messages : 7788
Enregistré le : septembre 27, 2002, 7:25 am

Message par Christophe »

Dernier message de la page précédente :

bou...

http://xdir.org , y a une pub pour les .fr ouvert au particulier
nightblade
Bernard pivot
Réactions :
Messages : 837
Enregistré le : janvier 15, 2003, 5:47 pm

Message par nightblade »

Je recherche la possibilitéed'avoir de la music sur le site que je fais mais le seul truc que m'a trouvé mon ami Google c'est un truc qui se lance de nouveau à chaque pages or moi ce que je veux c'est que la musique soit sur toute les pages sans redémarer à chaque nouvelle pages!! Si quelqu'un a une solution!!

PS: On dit qu'il y a trois millions de personnes qui veulent du travail. C'est pas vrai, de l'argent leur suffirait.
Avatar du membre
Aurelienazerty
Webmaster / Président
Réactions :
Messages : 22206
Enregistré le : septembre 27, 2002, 9:41 pm

simple

Message par Aurelienazerty »

C'est simple... Tu fais un sytème avec des frames, et dans une frame "invisible" (qualque pixels) tu met une page avec la musique... Voili voilou... C'est une astuce de srou...
nightblade
Bernard pivot
Réactions :
Messages : 837
Enregistré le : janvier 15, 2003, 5:47 pm

Message par nightblade »

lol oki je vas tester!!
nightblade
Bernard pivot
Réactions :
Messages : 837
Enregistré le : janvier 15, 2003, 5:47 pm

Message par nightblade »

si quelqu'un a la syntaxe ou un exemple pour l'utilisation des frames "invisibles" ça m'aiderais bien !! :sage: :adoration:

Voily Voilou!!
Avatar du membre
Christophe
L’humanité parlementaire
Réactions :
Messages : 7788
Enregistré le : septembre 27, 2002, 7:25 am

Message par Christophe »

c'est une frame normal.... mais tu rn créé une de 1 ou 2 pixel !!!
Avatar du membre
Davidazerty
l'élu
Réactions :
Messages : 2415
Enregistré le : octobre 12, 2002, 3:30 pm

Message par Davidazerty »

tu enleves les bordures aussi, sinon ca sert a rien ;)
Avatar du membre
Christophe
L’humanité parlementaire
Réactions :
Messages : 7788
Enregistré le : septembre 27, 2002, 7:25 am

Message par Christophe »

vi, lol
nightblade
Bernard pivot
Réactions :
Messages : 837
Enregistré le : janvier 15, 2003, 5:47 pm

Message par nightblade »

(ironique) Lol C'est justement la syntaxe que je cherchais!!
:dubitatif: :parking boulet:

Ce que je demande c'est si quelqu'un a la syntaxe (ou un exemple!!) car je n'ai encore jamais utilisé de frame!! #zinzin #zinzin
Avatar du membre
Aurelienazerty
Webmaster / Président
Réactions :
Messages : 22206
Enregistré le : septembre 27, 2002, 9:41 pm

C'est plus faire un site, mais faites moi mon site...

Message par Aurelienazerty »

Bon mika, ça serait pas mal que tu mettes en favoris les site comme le W3C... Ainsi que commentçamarche, voir que tu utilises google (ton amis de toujours)...
Sinon pour ta question, look ici
Bref, ne le prends pas mal, mais avant de demander, cherche un peu... :roll:
Avatar du membre
Christophe
L’humanité parlementaire
Réactions :
Messages : 7788
Enregistré le : septembre 27, 2002, 7:25 am

Message par Christophe »

moi je te conseil ça : http://www.commentcamarche.net/html/htmlintro.php3

français power pour un GTR ;-)
nightblade
Bernard pivot
Réactions :
Messages : 837
Enregistré le : janvier 15, 2003, 5:47 pm

Message par nightblade »

lol ça c'est une vrais réponse !! Merci !!! :adoration: :sage:
nightblade
Bernard pivot
Réactions :
Messages : 837
Enregistré le : janvier 15, 2003, 5:47 pm

Message par nightblade »

Pour les frames j'ai trouvé ce que je voulais mais ce que je veux faire c'est un lien qui pointe sur deux pages qui vont souvrir dans deux frames différentes mais le truc c'est que j'ai trouvé que ça :

Code : Tout sélectionner

<A HREF="http://www.lien1.net" TARGET="frame1" onClick="parent.top.location.href='http://www.lien2.com';return true;">groslien</a>
est c'est un peu lourd alors c'est juste pour savoir s'il exite plus simple!!
Avatar du membre
Christophe
L’humanité parlementaire
Réactions :
Messages : 7788
Enregistré le : septembre 27, 2002, 7:25 am

Message par Christophe »

si ça ça marche... c'est pas mal ;-)

plus simple, serai de créé une autre structure de frame.. mais en fait, non, c'est plus long....
Avatar du membre
Aurelienazerty
Webmaster / Président
Réactions :
Messages : 22206
Enregistré le : septembre 27, 2002, 9:41 pm

javascript

Message par Aurelienazerty »

Arf, un bout de code javascript:

Code : Tout sélectionner

<a name='lien' onClick='changerPage()'>Toto</a>

...

<Script language="Javascript" type="text/javascript">
function changerPage() {
   parent.top.frame1.location = 'http://www.lien1.net';
   location = "http://www.lien2.net";
}
</script>
ça t'ouvre le lien1.net dans la frame1 et le lien2.net dans la frame courante, parce que dans le bout de code que tu as donné, y doit y avoir une merdouille...
nightblade
Bernard pivot
Réactions :
Messages : 837
Enregistré le : janvier 15, 2003, 5:47 pm

Message par nightblade »

la fonction que tu ma donné aurel je la met dans le "head" ??

PS: si je veux mettre différent lien suivant le lien je dois bien faire

Code : Tout sélectionner

<a name='lien' onClick='changerPage("lien1","lien2")'>Toto</a> 


<Script language="Javascript" type="text/javascript"> 
function changerPage(a,b) { 
   parent.top.frame1.location = a; 
   location = b;
} 
</script> 
Avatar du membre
Aurelienazerty
Webmaster / Président
Réactions :
Messages : 22206
Enregistré le : septembre 27, 2002, 9:41 pm

yep

Message par Aurelienazerty »

Pour le script, tu le met dans le body...
ensuite pour la fonction, c'est juste ton bout de code...
nightblade
Bernard pivot
Réactions :
Messages : 837
Enregistré le : janvier 15, 2003, 5:47 pm

Message par nightblade »

La je comprend rien!!

Je vérif une page avec W3C mais ils me met des érreur que je comprend pas!!
exemple:
Line 15, column 35: there is no attribute "LEFTMARGIN"

<body bgcolor="#000000" leftmargin="0" topmargin="0" >
cf: w3c ...

edit by cricri: Mica attention au URL trop longue

:bute: :bute:
Avatar du membre
Nicolazerty
l'élu
Réactions :
Messages : 4050
Enregistré le : septembre 27, 2002, 2:59 pm

Message par Nicolazerty »

W3C a écrit :You have used the attribute named above in your document, but the document type you are using does not support that attribute for this element. This error is often caused by incorrect use of the "Strict" document type with a document that uses frames (e.g. you must use the "Transitional" document type to get the "target" attribute), or by using vendor proprietary extensions such as "marginheight" (this is usually fixed by using CSS to achieve the desired effect instead).
Résistance !
Avatar du membre
Aurelienazerty
Webmaster / Président
Réactions :
Messages : 22206
Enregistré le : septembre 27, 2002, 9:41 pm

super simple

Message par Aurelienazerty »

Ben c'est comme ils disent y a pas d'atributs leftmargin topmargin dans le body...
Faut le faire via une feuille de style (regarde comment c'est fait sur le site de la team)
nightblade
Bernard pivot
Réactions :
Messages : 837
Enregistré le : janvier 15, 2003, 5:47 pm

Message par nightblade »

lol oki mais je ne vois pas l'érreur sur la ligne 46 il me met 10 érreur du même type mais je vois pas commen les corrigér!!

les 2 érreurs que je comprend pas (et qui se répéte 10 foix):
Line 46, column 744: "PHOTO.PHP" is not a member of a group specified for any attribute

..."parent.top.location.href=\"Photo.php?dir=voyage\";return true;" class="SousC
Line 32, column 139: required attribute "ALT" not specified

...manuscrit_02.jpg" WIDTH=302 HEIGHT=20>
cf: w3c ...

Ps: lol je savais pasque je pouvais faire des URLs comme ça sur le forum!!
nightblade
Bernard pivot
Réactions :
Messages : 837
Enregistré le : janvier 15, 2003, 5:47 pm

Message par nightblade »

lol juste pour savoir comment on DLL easymod car je me pert dans le forum est je trouve aucun lien vers un DLL :oops: :oops:
Avatar du membre
Aurelienazerty
Webmaster / Président
Réactions :
Messages : 22206
Enregistré le : septembre 27, 2002, 9:41 pm

Aïe

Message par Aurelienazerty »

Mon dieu mes yeux :shock:

Pour tes erreurs: Je vois pas ce que tu ne comprends pas:
W3C a écrit :required attribute "ALT" not specified
ça veut dire, que l'atribut alt n'est pas spécifié... En d'autre mots, pour chaque image, il faut un texte alternatif (alt):

Code : Tout sélectionner

<img src="adresse" alt="texte alternatif">
Pour l'histoire de la ligne 46, met des ' au lieu de "

Pour easymod, après une recherche de 2s sur google (franchement tu pourrais chercher quand même) tu tombes sur cette page qui est on ne peut plus explicite... Ensuite, si tu veux plus d'information, tu vas sur le forum officiel d'easymod qui se trouve ici...

Ensuite concernant les liens et tout que tu peux mettre sur le forum, je te recommande la FAQ du forum disponiple ici
nightblade
Bernard pivot
Réactions :
Messages : 837
Enregistré le : janvier 15, 2003, 5:47 pm

Message par nightblade »

lol pour aesy mod en fait si je trouvé pas le lien c'est que je devais m'enregistrer!!!!!
Sinon j'avais trouvé cette page!!

sinon le probléme :

Aurélien a dit :

Code : Tout sélectionner

<img src="adresse" alt="texte alternatif"> 
Pour l'histoire de la ligne 46, met des ' au lieu de \"
je peus pas car c'est dans du php est si je met ' ça ferme l'echo!!!!
Avatar du membre
Aurelienazerty
Webmaster / Président
Réactions :
Messages : 22206
Enregistré le : septembre 27, 2002, 9:41 pm

boulet

Message par Aurelienazerty »

Aïe, en GTR ils nous vous apprennent vraiment rien...
Donc pour ne pas fermer ton ' de ton echo tu met un \'...
nightblade
Bernard pivot
Réactions :
Messages : 837
Enregistré le : janvier 15, 2003, 5:47 pm

Message par nightblade »

lol j'ai une dernière erreur que j'arrive pas à enlever c'est :

Code : Tout sélectionner

Line 64, column 86: non SGML character number 146

...height="31" align="left" alt=" " >n l¼/strong>’an 2004 de notre ère alors que des ce

car en fait il y à un << ' >> dans mon texte est je ne connais pas le code pour le renplacer!!!!
Répondre